1. 极安网首页
  2. 网络安全新闻

CVE-2020-12351/12352/24490:Linux内核BlueZ远程代码执行漏洞

CVE-2020-12351/12352/24490:Linux内核BlueZ远程代码执行漏洞-极安网

漏洞简述

2020年10月16日,google安全研究人员披露了三个linux内核蓝牙协议栈的漏洞,漏洞编号分别为CVE-2020-12351/12352/24490,包括一个高危漏洞和两个中危漏洞。

近距离的远程攻击者通过向受影响的主机发送特制的请求内容,可以在无需用户交互的情况下实现远程代码执行,目前POC和漏洞细节已经公开。

建议广大用户及时将linux-kernel升级到最新版本。与此同时,请做好资产自查以及预防工作,以免遭受黑客攻击。

风险等级

威胁等级:高危

影响范围:一般

漏洞详情

3.1 CVE-2020-12351:L2CAP堆类型混淆漏洞

Linux>=4.8的内核版本的源码net/bluetooth/l2cap_core.c存在一处堆类型混淆漏洞。 近距离的远程攻击者在知道受害者的蓝牙地址的情况下可以发送一个恶意的L2CAP数据包导致拒绝服务或者可能以内核权限执行任意代码。恶意蓝牙芯片也可以触发该漏洞。

3.2 CVE-2020-12352:A2MP栈信息泄露漏洞

Linux>=3.6的内核版本的源码net/bluetooth/a2mp.c存在一处栈信息泄露漏洞。 近距离的远程攻击者在知道受害者的蓝牙地址的情况下可以获得包含各种指针的内核栈信息,这些指针可以用来预测内存布局并绕过KASLR。也有可能能够泄漏如加密密钥等其它有价值的信息。恶意蓝牙芯片也可以触发该漏洞。

3.3 CVE-2020-24490:HCI event packet parser堆溢出漏洞

Linux>=4.19的内核版本的源码net/bluetooth/hci_event.c存在一处堆溢出漏洞。 近距离的远程攻击者可以广播数据,如果受害者机器装有蓝牙5芯片并处于扫描模式会导致拒绝服务或者可能以内核权限执行任意代码。恶意或存在漏洞的蓝牙芯片(如存在BLEEDINGBIT或类似的漏洞)也可以触发该漏洞。

影响版本

所以支持蓝牙协议栈的linux内核均受影响,部分常见受影响的linux发行版包括:

Red Hat Enterprise Linux 7/8

Ubuntu 20.04 LTS

debian 9/10/11

修复建议

建议将linux内核更新到5.9或更高版本。

确保安装如下补丁:

https://lore.kernel.org/linux-bluetooth/20200806181714.3216076-1-luiz.dentz@gmail.com/

https://lore.kernel.org/linux-bluetooth/20200806181714.3216076-2-luiz.dentz@gmail.com/

https://lore.kernel.org/linux-bluetooth/20200806181714.3216076-3-luiz.dentz@gmail.com/

https://lore.kernel.org/linux-bluetooth/20200806181714.3216076-4-luiz.dentz@gmail.com/

https://git.kernel.org/pub/scm/linux/kernel/git/bluetooth/bluetooth-next.git/commit/?id=a2ec905d1e160a33b2e210e45ad30445ef26ce0e

原创文章,作者: Admin ,转载请注明出处:https://secvery.com/2766.html